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คํานํา 

การจัดทําคูมือการปฏิบัติงานฉบับนี้ จัดทําขึ้นเพื่อเปนคูมือสําหรับการปฏิบัติงาน ดานการจัดทําแผนที่
เสนชั้นน้ําฝนเทา(Isohyet)ดวยโปรแกรม ArcGISใหกับเจาหนาที่ของฝายสารสนเทศและพยากรณน้ําและบุคคล
ที่สนใจ ใหเขาใจถึงขั้นตอนการจัดทําใหเกิดการเขาใจและนําไปใชใหเกิดประโยชนสูงสดุ 

คณะผูจัดทําหวังเปนอยางย่ิงวาคูมือการปฏิบัติงานนี้จะเปนประโยชนตอเจาหนาที่ของกรมชลประทาน 
สํานักบริหารจัดการน้ําและอุทกวิทยา สวนอุทกวิทยา ฝายสารสนเทศและพยากรณน้ํา ศูนยอุทกวิทยาภาคตางๆ 
รวมทั้งบุคคลที่สนใจ ใหเขาใจถึงขั้นตอนการจัดทําแผนท่ีเสนชั้นน้ําฝนเทา(Isohyet)ดวยโปรแกรม ArcGIS และ
นอกจากนี้ยังใชเปนแนวทางในการดําเนินการไดอยางเปนระบบ มีประสิทธิภาพและเกิดประสิทธิผล บรรลุผล
สําเร็จตามหลักเกณฑตัวชี้วัดของการจัดการความรู (Knowledge Management: KM)สํานักบริหารจัดการน้ํา
และอุทกวิทยา กรมชลประทาน 
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คูมือการปฏิบัติงาน 
การจัดทําแผนท่ีเสนชั้นน้าํฝนเทา (Isohyet) 

 

1. วัตถุประสงค 

๑.๑ เพื่อจัดทําคูมือการจัดทําแผนที่เสนชั้นน้ําฝนเทา(Isohyet)ปริมาณฝนที่ตกสะสมในพื้นท่ีของ
ประเทศไทยยอนหลัง30ป ทําใหทราบถึงความเขมฝนในรอบ30ป ในพื้นท่ีประเทศไทยโดยแสดงขั้นตอนการ
จัดเตรียมขอมูลนําเขาสําหรับการนําเขาโปรแกรม การวิเคราะหดวยโปรแกรม และการแสดงผลลัพธของแบบ
โปรแกรมรวมทั้งเปนการสรางมาตรฐานใหเกิดการใชขอมูลปริมาณฝนไดอยางมีประสิทธิภาพ และนําขอมูลไปใช
เพื่อใหเกิดประโยชนสูงสุด 

๑.๒ เพื่อเปนขอมูลเบื้องตนในการจัดทําแผนที่เสนชั้นน้ําฝนเทา(Isohyet) ดวยโปรแกรม ArcGIS ให
ผูปฏิบัติงานเขาใจข้ันตอนการจัดทํา และเผยแพรใหกับบุคคลภายนอกไดเขาใจกระบวนการจัดทําและการใช
โปรแกรม ArcGIS 

๑.๓ เพื่อใชเปนเครื่องมือในการศึกษาและประยุกตใชโปรแกรม ArcGISเพื่อการจัดทําแผนที่เสนชั้น
น้ําฝนเทา(Isohyet) ในพื้นท่ีของประเทศไทย 

2. ขอบเขต 

คูมือการการจัดทําแผนที่เสนชั้นน้ําฝนเทา(Isohyet)สําหรับผูปฏิบัติงานท่ีเก่ียวของ ไดแก นักอุทกวิทยา 
ลูกจาง พนักงานราชการ ที่มีการเปลี่ยนแปลง โอน/ยาย/เขามาใหม ซึ่งประกอบดวยขั้นตอนสําคัญดังน้ี 

2.1. เลือกสถานีวัดปริมาณฝนที่จะใชขอมูล 

2.2. ตรวจสอบความถูกตองและความตอเนื่องของขอมูล 

2.3. สรางแผนที่เสนชั้นน้ําฝนเทา(Isohyet) ดวยโปรแกรม ArcGIS 

2.4. แสดงแผนที่เสนชั้นน้ําฝนเทา(Isohyet) 

๓. คําจํากัดความ 

๓.๑ เสนชั้นน้ําฝนเทา(Isohyet)คือเสนที่ลากผานบริเวณที่มีความลึก หรือปริมาณน้ําฝนเทากัน โดย
อาศยัขอมูลปริมาณฝนที่ไดจากสถานีวัดน้ําฝนเปนหลัก และพิจารณาจากแผนที่ภูมิประเทศ โดยดูจากสภาพภูมิ
ประเทศ ลักษณะภูมิประเทศ ทิศทางพายุ ฝน เปนตน  

๓.๒ วิธีInverse Distance Weight (IDW) เปนการประมาณคาโดยทําการสุมจุดตัวอยางแตละจุด
จากตําแหนงที่สามารถสงผลกระทบไปยังเซลลที่ตองการประมาณคาได ซึ่งจะมีผลกระทบนอยลงเรื่อยๆ 
ตามระยะทางที่ไกลออกไป เหมาะกับตัวแปรท่ีอางอิงกับระยะทางในการคํานวณ 

๓.๓ โปรแกรม ArcGISเปนชุดโปรแกรมประยุกตระบบสารสนเทศภูมิศาสตรชุดโปรแกรมหนึ่ง ซึ่งใช
ในการจัดการขอมูลภูมิสารสนเทศ เพื่อตอบสนองความตองการการใชงานของหนวยงานตางๆ  

3.4     ปริมาณฝนรายวันคือปริมาณฝนที่ตกสะสมลงบนพื้นดินคิดเปนความสูงของน้ําฝนที่ตกสะสม 
ลงบนพื้นดินและสามารถวัดไดดวยเครื่องวัดฝน มีหนวยในการวัดเปนมิลลิเมตร ในชวงระยะเวลาตั้งแต 
07.00 น.ของเมื่อวานนี้จนถึง เวลา 07.00 น.ของวันนี้รวมเปนระยะเวลา 24 ชั่วโมง 



๒ 

3.5     สถานีวัดปริมาณฝนคือเครื่องมือบันทึกขอมูลปริมาณน้ําฝนที่ตกในพื้นท่ีที่เราตองการสํารวจ 
และนําขอมูลปริมาณน้ําฝนนั้นมาวิเคราะห พยากรณในวาในปตอไป จะมีปริมาณน้ําฝนเปนอยางไร สวนใหญ 
ใชมาตรวัดเปนมิลลิเมตร  

3.6     กราฟทับทวี (double-mass curve)เปนวิธีเปรียบเทียบปริมาณน้ําฝนสะสมรายเดือน 
ของสถานีท่ีตองการตรวจสอบกับคาปริมาณน้ําฝนสะสมรายเดือนที่เฉลี่ยมาจากสถานีที่อยูรอบขาง  

3.7     วิธีสัดสวนปกติ (Normal Ratio Method)เปนวิธีที่ใชในกรณีที่ขอมูลน้ําฝนแตกตางกันมาก 
ในแตละสถานี ซึ่งใชคาเฉลี่ยปริมาณน้ําฝนตลอดปเกณฑการเปรียบเทียบ  

3.8พิกัด XY ทางภูมิศาสตรคือคาที่ใชบอกพิกัดทางภูมิศาสตร โดยจะระบุในรูปแบบของตัวเลข 
ซึ่งการระบุพิกัดทางภูมิศาสตรจะมีตัวเลข 2 ชุด เรียกวา เลขละติจูด (Latitude) และเลขลองจิจูด (Longitude) 

๔. หนาที่ความรับผิดชอบ 

๔.๑ ผูอํานวยการสวนอุทกวิทยา รับทราบและสนับสนุนการจัดทําแผนท่ีเสนชั้นนํ้าฝนเทา(Isohyet) 
๔.๒ หัวหนาฝายสารสนเทศและพยากรณน้ํา พิจารณากลั่นกรอง และตรวจสอบความถูกตอง 

ในการจัดทําแผนที่เสนชั้นน้ําฝนเทา (Isohyet) 
๔.๓ ผูปฏิบัติงานในลุมน้ําท่ีรับผิดชอบการจัดทําแผนที่เสนชั้นน้ําฝนเทา (Isohyet)จัดเตรียมขอมูล

ปริมาณฝนยอนหลัง 30ป เพื่อใชเปนขอมูลนําเขาสําหรับวิเคราะหโดยโปรแกรม ArcGIS 



๓ 

สรุปกระบวนการการจัดทําแผนที่เสนชั้นน้ําฝนเทา (Isohyet) 

กระบวนกาการจัดทาํแผนที่เสนชั้นน้ําฝนเทา (Isohyet)กรมชลประทานประกอบดวยขั้นตอนสําคัญดังนี้ 

1. เลือกสถานีที่ตองการจะจัดทําเสนชั้นน้ําฝนเทา (Isohyet) 

2. ตรวจสอบพิกัดของสถานีที่เลือกใหครอบคลุมท่ัวพื้นที่ศึกษา 

3. รวบรวมขอมูลปริมาณฝนรายวันของสถานีที่เลือกยอนหลัง30ป 

4. ตรวจสอบความถูกตองและความตอเนื่องของขอมูล 

5. จัดรูปแบบขอมูลใหอยูในไฟล Excel  

6. นําขอมูลเขาโปรแกรม ArcGISเพื่อวิเคราะหและแสดงผลออกมาเปนแผนที่เสนชั้นนํ้าฝนเทา(Isohyet) 
7. ตรวจสอบความถูกตองของแผนที่เสนชั้นน้ําฝนเทา(Isohyet) 

8. เผยแพรขอมูล 

  



๔ 

Work Flow กระบวนการจัดทําแผนที่เสนชั้นนํ้าฝนเทา(Isohyet)กรมชลประทานในภาพรวม 

ลําดับ    ผังกระบวนการ      เวลา 
 
 

๑.           1ชั่วโมง 
 
 
 
 

๒. 1 ชั่วโมง 
 
 
 
๓. 48 ชั่วโมง 
 
 

๔. 20 ชั่วโมง
  
 
 
 
5 30 นาที 
 
 
 

๖.  40 นาที 
 
 
 
 

๗. 40นาที 
 
 
 
 
๘. ๑๐ นาท ี
 

รวมเวลาท้ังหมด 72ชั่วโมง 

นําเขาขอมูลปริมาณฝนในโปรแกรม ArcGIS และวิเคราะหออกมา
เปนแผนที่เสนชั้นน้ําฝนเทา 

 

ตรวจสอบความถูกตองของ
ขอมูลท่ีไดจาก ArcGIS 

เผยแพรขอมูลในเว็บไซต 

Yes 

No 

ตรวจสอบความตอเนื่องและ
ถูกตองของขอมูลปริมาณฝน 

Yes 

รวบรวมขอมูลปริมาณฝนรายวันยอนหลัง 30 ป 

จัดรูปแบบขอมูลเปนไฟล Excel 
 

กําหนดสถานีตรวจวัดปริมาณฝนฝน 
ที่จะนําขอมูลมาใช 

ตรวจสอบพิกัดสถานีของสถานีให
ครอบคลุมพ้ืนที่ท่ัวประเทศ 

Yes 

No 

No 
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5. Work Flow 

ชื่อกระบวนการ: จัดทําแผนที่เสนชั้นน้ําฝนเทา(Isohyet) 
ตัวชี้วัดผลลัพธกระบวนการการจัดทําคูมือปฏิบัติงาน: ความถูกตองของขอมลูที่แสดงในเว็บไซต ฝายสารสนเทศและพยากรณน้ํา สวนอุทกวิทยา 

ลําดับ ผงักระบวนการ 
ระยะ 
เวลา 

รายละเอียดงาน มาตรฐานคุณภาพงาน ผูรับผิดชอบ 

 
1 
 
 
 
 
 

 
2 
 
 
 

3 
 

 
 

 
 

4 
 

 
 

 
 
 
 
 
 
 
 
 
 
 

 
 
 
 

 
 
 

 

 
1 ชั่วโมง 

 
 
 
 

1 ชั่วโมง 
 
 

 
 
48 ชั่วโมง 
 
 
  
 
20 ชั่วโมง 
 
 

 

 
๑. คัดเลือกสถานีตรวจวัดปริมาณฝนที่จะ
นําขอมูลมาใชใหครอบคลุมเขตพื้นท่ีทั่ว
ประเทศ หรือสถานีท่ีสนใจในการติดตาม
เฝาระวังในพื้นท่ีสําคัญ 
 
๑. ตรวจสอบพิกัดของสถานีวัดปริมาณฝนท่ี
เลือกใหครอบคลุมพื้นที่ประเทศ 
 
 
 
๑. รวบรวมขอมูลปริมาณฝนยอนหลัง 30 
ปของสถานีท่ีกําหนดใว 
 
 
 
๑. ตรวจสอบความถูกตองของขอมูล โดยดู
จากขอมูลเวลากอนหนาวาขอมูลที่ไดมามี
ความผิดปกติหรือไม 
 

 
- สถานีวัดปริมาณฝนที่คัดเลือกเปน
สถานีท่ีตรวจวัดมาเปนระยะเวลา
ยาวนานถึงปจจุบัน สามารถนําขอมูล
มาจัดทําแผนท่ีเสนชั้นน้ําฝนเทาได 
 
-สถานีวัดปริมาณฝนกระจายตัวอยู
ทุกจังหวัดในปริมาณท่ีเหมาะกับกับ
พื้นที่ของจังหวัด 
 
 
- ขอมูลปริมาณฝนเปนขอมูลปริมาณ
ฝนรายวันของหลายๆหนวยงานเชน 
กรมชลประทาน กรมอุตุนิยมวิทยา 
กรมทรัพยากรน้ํา 
 
- ขอมูลมีความนาเชื่อถือ ตอเนื่องไม
ขาดหาย และยาวนานถึงปจจุบัน 
- ปรับแกขอมูลใหถูกตอง และตอ
ขอมูลชวงท่ีขาดหายใหสมบูรณ 

 
เจาหนาที่ ของ
ฝายสารสนเทศ
และพยากรณ
น้ํา 

 
เจาหนาที่ ของ
ฝายสารสนเทศ
และพยากรณ
น้ํา 

 
เจาหนาที่ ของ
ฝายสารสนเทศ
และพยากรณ
น้ํา 

 
เจาหนาที่ ของ
ฝายสารสนเทศ
และพยากรณ
น้ํา 

Yes 

No 

รวบรวมขอมูลปริมาณฝน
รายวันยอนหลัง 30 ป 

กําหนดสถานีตรวจวัดปริมาณฝน 
ท่ีจะนําขอมูลมาใช 

 ตรวจสอบพิกัดสถานีของสถานีให
ครอบคลุมทั่วประเทศ 

 ตรวจสอบความถูกตอง 
ของขอมูล 

No 

Yes 
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5 
 
 
 
 

6 
 
 

 
7 
 
 
 
 
 

8 
 
 
 

 
 

 

 
 
 
 

 
 
 
 
 
 
 
 
 
 

 
 
 

 
30 นาที 

 
 
 
4๐ นาที 
 
 
 
 
4๐ นาที 

 
 
 
 
1๐ นาที 

 
 
 
 
 

 
๑. จัดรูปแบบขอมูลใหอยูในรูปแบบไฟล 
Excelเพื่อนําเขาโปรแกรม ArcGIS 
 
 
๑. นําขอมูลมาวิเคราะหโปรแกรม ArcGIS 
 
 
 
 
๑. ตรวจสอบขอมูลวาถูกตองสมบูรณ
หรือไมโดยตรวจสอบจากสีตางๆบนแผนที ่
 
 
 
๑. แสดงผลขอมูลในรูปแบบแผนท่ีและนํา
ขึ้นแสดงบนเวบ็ไซต 

 
- ไฟล  Excelมีขอ มูลพิ กัด  ขอมูล
ปริมาณฝนของสถานีที่กําหนดใว 
 
 
- วิ เคราะหข อ มูลด วยคําสั่ งของ
โปรแกรม ArcGIS 
- แสดงขอมูลออกมาเปนแผนที่เสน
ชั้นนํ้าฝนเทา 
 
- ข อ มู ล ที่ แ ส ด งมี ค ว าม ถูกต อ ง
ครบถวนสมบูรณมีความสัมพันธท่ีด ี
 
 
 
- ขอมูลถูกตองและครบถวน 

 
เจาหนาที่ ของ
ฝายสารสนเทศ
และพยากรณ
น้ํา 
เจาหนาที่ ของ
ฝายสารสนเทศ
และพยากรณ
น้ํา 
 
เจาหนาที่ ของ
ฝายสารสนเทศ
และพยากรณ
น้ํา 

 
เจาหนาที่ ของ
ฝายสารสนเทศ
และพยากรณ
น้ํา 

 

จัดรูปแบบขอมูลเปนไฟล Excel 
 

นําเขาขอมูลปริมาณฝนในโปรแกรม 
ArcGIS และวิเคราะหออกมาเปนแผน
ท่ีเสนชั้นน้ําฝนเทา 

 
ตรวจสอบความถูกตองของ

ขอมูลทีไ่ดจาก ArcGIS 
 

Yes 

แสดงผลขอมูลในเวบ็ไซต 
 

No 
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๖. ข้ันตอนการปฏิบัติงาน 
 6.1 การเลือกสถานีที่จะทําการสรางเสนชั้นนํ้าฝน 
 6.1.1 เปนสถานีท่ีมีการเก็บขอมูลตอเนื่อง และมีชวงระยะเวลาการเก็บขอมูลท่ียาวนาน 
 6.1.2 เปนสถานีท่ียังเปดใชงานจนถึงปจจุบัน 

6.1.3 เปนสถานีท่ีมีความสําคัญและตําแหนงของสถานีกระจายอยูทั่วพื้นที่ศึกษา 
 6.2 การตรวจสอบขอมูลที่ขาดหายไป 

6.2.1 การวิเคราะหดวยวิธีกราฟทับทวี (Double-mass curve) กรณีที่ขอมูลถูกตอง กราฟที่ได
จะมีลักษณะเปนเสนตรง 

6.2.2 การเตมิขอมูลดวยวิธีสัดสวนปกติ (Normal Ratio Method) เปนการหาคาปริมาณน้ําฝน
ที่หายไปและตองการประมาณข้ึนมาโดยคาเฉลี่ย 
 6.3 การสรางเสนช้ันน้าํฝนดวยโปรแกรม ArcGIS 

6.3.1 การนําคาพิกัด XY มาสรางชั้นขอมูล Point โดยโปรแกรม ArcGIS 
-นําคาพิกัด XY และรายละเอียดตางๆ ลงในโปรแกรม Excel และบันทึกเปนไฟล 

Excel 97-2003 

 
 

-เปดโปรแกรม ArcGISขึ้นมา และไปที่เมนู File > Add Data > Add XY Data… 
จะปรากฏหนาตางดงัภาพ 
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-คลิ ก ท่ี เลือกไฟล Excel ที่ไดทําการบันทึกไวขางตน >คลิก Add > 
เลือก Sheet ที่มีขอมูล >คลิก Add 

 
-ชอง X Field (จะเปนคาพิกัด Longitude หรือคา Easting) เลือก Longitudeและชอง Y 

Field (จะเปนคาพิกัด Latitude หรือคาNorthing) 
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-ที่ชอง Coordinate System of Input Coordinates คลิกท่ี Edit 
>GeographicCoordinate System > World > WGS 1984 

 
 

-เม่ือเลือกระบบพิกัดแลว คลิก OK > OK  

 
 

-จะไดจุดพิกัดดังภาพ 
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- คลิกขวาที่ชั้นขอมูล > Data > Export Data… 
 

 
 

- คลิกที่  เพ่ือเลือก Directory ที่ตองการบันทึกขอมูล แลวคลิก Save > OK 

 

 
 

- จะไดชั้นขอมูล Point ที่เปน Shapefile พรอมขอมูลใน Attributes เพื่อนําไปใชงาน 
 

 



6.3.2 ขั้นตอนการประมาณคาในชวงรปูแบบ 
- นําเขาขอมูลของสถานีวัดน้ําฝนและขอบเขตของพื้นที่ศึกษา โดยใชคําสั่ง 

Data หลังจากนั้นคลิกที่ ArcToolbox

- เลือก 3D Analysis Tools >
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ขั้นตอนการประมาณคาในชวงรูปแบบ Inverse Distance Weighted (IDW)
นําเขาขอมูลของสถานีวัดน้ําฝนและขอบเขตของพื้นท่ีศึกษา โดยใชคําส่ัง 

ArcToolbox 

 

Analysis Tools > Raster Interpolation > IDW 

Inverse Distance Weighted (IDW) 
นําเขาขอมูลของสถานีวดันํ้าฝนและขอบเขตของพ้ืนที่ศึกษา โดยใชคาํส่ัง Add 
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- จะปรากฏหนาตางดงันี้ 
 

 
 

 

คําสั่ง ความหมาย 

Input point features  กําหนดขอมูลจดุที่ตองการประมาณคา (ในที่น้ีคอื สถานีวัดน้ําฝน) 

Z value field  กําหนดฟลดใน Attribute ที่ตองการประมาณคา (ปริมาณฝนในแตละสถานี) 

Output raster  กําหนด Directory ที่ตองการบันทกึขอมูล 

Output cell size (optional)  กําหนดขนาดเซลลผลลัพธ 

Power (optional)  ตัวยกกําลังของสมการ 
 

- จากนั้นคลิกที่ Environments 
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- ปรากฏหนาตาง Environment Settings ท่ีตัวเลือก Processing Extent คลิก 
เลือกขอบเขตพื้นที่ศึกษา โปรแกรมจะใสคาพิกัดของขอบเขตใหอัตโนมัติ 

 

 
 

- ที่ตัวเลือก Raster Analysis คลิกที่ลูกศร เลือกพื้นที่ขอบเขตที่ตองการตัดขอมูล 
(ในกรณีที่เพิ่ม Shapefileเขามายัง Data Frame แลว) หรือคลิก เพื่อเลือกขอมูลที่ยังไมไดเพิ่มเขา
มายัง Data Frame 

 
 

- จากนั้นคลิก OK> OK 
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- จะปรากฏผลลัพธดังภาพ 

 

 
 

6.3.1 ขั้นตอนการกําหนดสีและชวงของปริมาณนํ้าฝน 

- คลิกขวาที่ Shapefile เลือก Properties 

 

 
 

- เลือก Symbology > Classified > Classify 
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- กําหนดจํานวนและชวงของปริมาณนํ้าฝนตามที่ตองการ จากนั้นคลิก OK 

 

 
 

- กําหนดสีโดยการดับเบิลคลิก และกําหนดคาตัวเลขที่ตองการใหแสดงจากนั้นคลิก OK 

 

 
 

 
 
 



16 

- จะไดผลลัพธดังรูป 

 

 
 

- ขั้นตอนตอมาทําการเพิ่มขอมูลท่ีตองการแสดงตามตองการและทําการ Export Map 
เพื่อนําแผนท่ีไปใชงานตอไป 
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7. ระบบติดตามประเมินผล 

กระบวนการ มาตรฐาน/คุณภาพงาน 
วิธีการติดตาม
ประเมินผล 

ผูติดตาม/
ประเมินผล 

ขอเสนอแนะ 

1 .กา ร จั ด เ ต รี ย ม
ขอมูล 
 
 
 
 
 
 
 
 
 
 
 
 
 
2. การวิเคราะห
ขอมูลดวยโปรแกรม
ArcGIS 
 
 
 
 
 
 
 
 
 
 
 
 
3. การแสดงผล 
 
 
 
 

1. การเลือกสถานีที่จะ
ทํ า ก า ร ส ร า ง เ ส น ชั้ น
น้ําฝน 
2. การรวบรวมและ
ตรวจสอบข อมูล ให มี
ค ว า ม ต อ เ นื่ อ ง  แ ล ะ
นาเชื่อถือ 
 
 
3 .  จั ด รูป แบบข อ มูล 
เพื่ อนํ า เข า โปรแกรม 
ArcGIS  
 
 
 
1. การนําคาพิกัด XY 
มาสรางชั้นขอมูล Point 
2 .  กา ร ประ มาณค า
ในชวงรูปแบบ Inverse 
Distance Weighted 
(IDW) 
 
 
 
 
 
 
3. การกําหนดสีและ
ชวงของปริมาณน้ําฝน 
 
1. แสดงผลในรูปแบบ
แผนที่ 

1. ครอบคลุมท่ัวพื้นที่
ศึกษา 
 
2. วิเคราะหดวยวิธี
ก ร า ฟ ทั บ ท วี 
(double-mass 
curve)และเติมขอมูล
ที่ ข า ด ห า ย ด ว ย
แบบจําลอง HEC-4 
3. จัดรูปแบบขอมูล
เ ป น ไ ฟ ล  Excel 
ประกอบดวยขอมูล 
สถานี ,พิกัด ,ปริมาณ
ฝน 
 
1. ตรวจสอบความถูก
ตองของตําแหนงพิกัด 
2. เปนการประมาณ
คาโดยทําการสุมจุด
ตัวอยางแตละจุดจาก
ตําแหน งที่ สามารถ
ส งผลกระทบไปยั ง
เ ซ ล ล ที่ ต อ ง ก า ร
ประมาณคาได ซึ่งจะ
มีผลกระทบนอยลง
เรื่อยๆ ตามระยะทาง
ที่ไกลออกไป 
3. กําหนดสีและชวง
ขอมูลใหถูกตอง 
 
1. ตรวจสอบผลใหมี
ค ว า ม สั ม พั น ธ กั บ
ปริ มาณฝน ท่ีตกใน 
แตละสถานี 

- หั ว ห น า ฝ า ย
สารสนเทศแล ะ
พยากรณน้ํา 
- ผูจัดทําเสนชั้น
น้ําฝนเทา 
 
 
 
 
 
 
 
 
 
 
- หั ว ห น า ฝ า ย
สารสนเทศแล ะ
พยากรณน้ํา 
- ผูจัดทําเสนชั้น
น้ําฝนเทา 
 
 
 
 
 
 
 
 
 
 
- หั ว ห น า ฝ า ย
สารสนเทศแล ะ
พยากรณน้ํา 
- ผูจัดทําเสนชั้น
น้ําฝนเทา 

 



 

๑๘ 

๘. ปญหาและขอเสนอแนะ 

๘.1ขอมูลปริมาณฝนของสถานีไมมีความตอเนื่อง และไมถูกตอง  
8.2ในขั้นตอน IDW ที่คําสั่ง Enviroment Settings กรณีที่ไมไดกําหนดขอบเขตของ Processing 

Extent อาจทําใหขอมูล Raster ที่ไดจากการ IDW ไมคลอบคลุมท่ัวท้ังพื้นที่ศึกษา ดังรูป 
 

 
 

 

๙. แบบฟอรมที่ใช 

 ๙.1 แบบฟอรมขอมูลปริมาณฝนที่ไดมาจากการรวบรวมขอมูล ในรูปแบบไฟล Text ไฟล 

 ๙.2 แบบฟอรมการนําเขาโปรแกรม ArcGIS 
   
  



 

๑๙ 

 
 
 

ภาคผนวก 

  



 

๒๐ 

ตัวอยางแบบฟอรมการนําเขาขอมูลของสถานีตางๆ ในรูปแบบ Excel 

 

 
 

ตัวอยางการเลือกสถานีใหครอบคลุมท่ัวพื้นที่ศกึษา 
 

 
 
 
 



 

๒๑ 

ตัวอยางการบันทึกสีและชวงของขอมูลที่ไดทําการตั้งคาไว  
- คลิกขวาที่ Layers เลือก Save As Layer File 
 

 
 

- เลือก Directory ที่ตองการบันทึกขอมูล แลวคลิก Save 
 

 
 
ตัวอยางการตั้งคาขอมูลโดยอางอิงจากLayer ที่ไดทําการตั้งคาไวแลว 

- ที่เมนู Classified คลิก จะปรากฏหนาตาง Import Symbology คลิก  เลือก 
Layer ที่ไดทําการบันทึกไวกอนหนานี้จากนั้น คลิก Add > OK 

 

 


