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บทที่ 1 แนะนําโปรแกรม 

 

1.1 โปรแกรม ArcGIS คืออะไร 

โปรแกรม ArcGIS เปนชุดโปรแกรมประยกุตระบบสารสนเทศภูมิศาสตรชุดโปรแกรมหนึ่ง ซ่ึง
ใชในการจัดการขอมูลภูมิสารสนเทศ เพื่อตอบสนองความตองการการใชงานของหนวยงานตาง ๆ ทั้ง
ภาครัฐและเอกชน สถานศึกษา ฯลฯ ผลิตและจัดจําหนายโดยบริษัท ESRI จํากัด 
 

1.2 องคประกอบของ ArcGIS 

องคประกอบของ ArcGIS  ประกอบดวย ชุดโปรแกรม ArcView ArcEditor ArcInfo เพื่อการ
นําเขา, แกไข, วิเคราะห และแสดงผลแผนที่ ชุดโปรแกรม ArcSDEและ Enterprise Database เพื่อการ
จัดการระบบฐานขอมูลเชิงพื้นที่ ชุดโปรแกรม ArcIMS เพื่อการใหบริการแผนที่ผานเครอืขาย
อินเตอรเน็ต  
 

 

 

 

 

 

 

 

รูปท่ี 1 – 1   องคประกอบของ ArcGIS 
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1.3 ชุดโปรแกรม ArcEditor 

ArcView มีความสามารถในการเรียกดูขอมูล ( Data Visualization) สืบคนขอมูล (Query) 
วิเคราะห (Analysis) และสรางแผนที่ (Map creation) โดยมีเครื่องมือสําหรับสํารวจดูขอมูล (Exploring) 
เลือกบริเวณทีส่นใจ (Selecting) แสดงผล (Displaying) ปรับแกขอมูล (Editing) วิเคราะห (Analyzing) 
ใหสัญลักษณ (Symbolizing) และจําแนกชัน้ขอมูล (Classifying data) รวมทั้งสามารถสราง ปรับแกและ 
จัดการ metadata โครงสรางของโปรแกรม ArcView ประกอบดวย ArcMap, ArcCatalog และ 
ArcToolbox. 
 

 

 

 

 

 

 

 

 

รูปท่ี 1 – 2   โครงสรางของโปรแกรม ArcView รวมท้ังโครงสรางทั้งหมดของ ArcGIS  

และโปรแกรมเพิ่มเติม (Extensions) 
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1.4 โปรแกรมประยุกต ArcMap, ArcCatalog และ ArcToolbox 

ArcMap  ใชสําหรับแสดงภาพ ปรับแกขอมูลเชิงพื้นที่ สรางแผนที่ กราฟ และรายงาน 
ฐานขอมูล GIS จะแสดงบนแผนที่ที่เรียกวาชั้นขอมูล (Layer) ในแตละชั้นขอมูล จะแยกเปนขอมูลแตละ
ประเภททีจ่ัดเก็บ สวนบริเวณ Table of Content (TOC) ของ ArcMap จะแสดงรายการของชั้นขอมูลบน
แผนที่ โดยคาตั้งตนของ TOC จะอยูดายซายมือแตสามารถ เคล่ือนไปอยูตําแหนงอ่ืน ๆ ไดตามตองการ 
สําดับการวางชั้นขอมูลใน TOC จะเปนลําดับ การแสดงขอมูลในสวนแสดงแผนที ่ลําดับที่อยูบนสดุก็จะ
แสดงภาพอยูบนสุดดวย ดังนั้นควร นําขอมูลที่เหมาะเปนฉากหลัง ไวลางสุด 

ArcCatalog เปนโปรแกรมประยุกตที่ใชติดตอกับฐานขอมูล มีประสิทธิภาพหลักคอืมี
ความสามารถเลือกเสนทางขอมูล (browse) ดูโครงสรางการจัดเก็บขอมูล (organize) จําหนายจายแจก
เอกสารแผนทีห่รือขอมูล หนากากของ ArcCatalog มีลักษณะคลายกบั Windows Explorer แตตางกันที่
สามารถเรียกดขูอมูล แผนที่ และเมตะดาตา (metadata) ได 

ArcToolbox เปนเครื่องมือชวยในการวิเคราะหขอมูล GIS ขั้นสูง เชน การแปลงระบบพิกดั 
หรือแปลงประเภทขอมูลจากชนิดตาง ๆ ไปเปน Geodatabase ดวยการทํางานแบบ drag and drop ทําให
สามารถลากชื่อและเสนทางของขอมูลจาก ArcCatalog ไปยัง ArcToolbox ได 
 

1.5 สรุป 

 
ArcGIS แบงเปนระดับการนําไปใชงาน 3 ระดับซึ่งมีช่ือเรียกตางกันออกไปคือ ArcView, 

ArcEditor และ ArcInfo ซ่ึงการเลือกนําไปใชงานแกองคกรตองคํานึงถึงความตองการขององคกรนั้น ๆ 
เชน ขนาด และการใชงานของฐานขอมูล การใชงานภายใตระบบเครือขาย ฯลฯ ArcGIS ทั้งหมดสราง
มาจากเทคโนโลยี่ Component Object Model (COM) ซ่ึงมีประสิทธิภาพสูงสามารถใหผูใชปรับแกไข
เองไดหลายสวน รวมทั้งสราง extensible ไวใชเอง  

ArcGIS ทุก ๆ ประเภทจะประกอบดวยโปรแกรมประยกุต 3 โปรแกรมดวยกันคือ ArcCatalog 
ArcMap และ ArcToolbox ซ่ึงโปรแกรมประยุกตทั้งสามสามารถเชื่อมโยงกันในลักษณะ interact ทั้งจาก
ขอมูล GIS แผนที และเครื่องมือตาง ๆ  

ArcCatalog ใชเพื่อเขาถึง สรางฐานขอมูล และปรับแก metadata สวน ArcMap เหมาะสําหรับ
แสดง ปรับแก สืบคนขอมูล และสรางเอกสารแผนที่ สําหรับ ArcToolbox เหมาะสําหนับวเิคราะหทาง
ภูมิศาสตร มีเครื่องมือและเครื่องมือวิเศษสําหรับชวยในการวิเคราะหและแปลงประเภทขอมูล  
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ก) ArcMap 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 ข) ArcCatalog ค) ArcToolBox 

 
รูปท่ี 1 – 3   ลักษณะหนาจอของ ArcMap, ArcCatalog และ ArcToolBox 
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บทที่ 2 การใชงานโปรแกรม ArcGIS 9.2 

 

2.1 การสราง Personal Geodatabase 
 

- Click start menu > Programs > ArcGIS > ArcCatalog  

 
 
- ไปที่ Directory ที่ตองการเกบ็ Personal Geodatabase แลว Click ขวา 
- Click New ( 1 ) 
- Click  ( 2 ) 
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- ตั้งชื่อ Geodatabase ที่สรางขึ้น 

 
- จาก Geodatabase นี้สามารถสรางฐานขอมูล นําเขาขอมูล รวมถึงจัดการฐานขอมูลใน

เร่ืองตาง ๆ ไดตอไป 
 

2.2 การนําเขาขอมูล 
 

การนําเขาขอมูลจาก Shape File ไปสู Geodatabase 
 

โดยการเลือกที่ Shape File ที่จะทําการ Export แลวคลิกเมาดานขวา  
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- จะปรากฏหนาตาง Export data ขึ้นมา 
- ในชอง Export เลือก Export to Geodatabase (multiple).. 
- จะไดกลอง Toolbox(Feature Class to Geodatabase (multiple)) ขึ้นมา 

 

- เลือก Directory ที่ตองการเกบ็ขอมูลไวที่ Geodatabase  ช่ือ DPT.mdb  
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- Click add 

 
 

- Click OK 

 

 -8- 



คูมือการใชโปรแกรมระบบสารสนเทศภูมิศาสตร ArcGIS 9.2 
 

- เสร็จแลวขอมลูก็จะเขาไปอยูใน Geodatabase ที่ตองการ 
 

 
 

การนําเขาขอมูลจาก ArcInfo (coverage) เพื่อนําไปเก็บไวท่ี Geodatabase  
 

- Start ArcCatalog ไป Click ขวาที่ coverage แลวเลือก Export ; เลือก To Geodatabase 
(Multiple) 

 
 

- จะปรากฏหนาตาง Export data ขึ้นมา 
- ในชอง Export เลือก Export to Geodatabase (multiple).. 
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- จะไดกลอง Toolbox(Feature Class to Geodatabase (multiple)) ขึ้นมา 
- ในชอง Input Features จะมช้ัีนขอมูลที่เลือกไวเขาไปโดยอัตโนมัติ  
- ในชองของ Output Geodatabase ใหเลือก File Geodatabase โดยไปที ่ Directory ที่เกบ็

GeoDatabase (DPT.mdb)ที่มีอยูแลวเลือกเขามา 
- Click OK 

 
 

- เมื่อเสร็จแลวขอมูลจะเขาไปอยูใน Geodatabase ดังแสดงในรูป 
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การนําเขาขอมูล Point จากตาราง 
 

- บันทึกขอมูลพกิัด x, y ในรูปแบบของ text file 
 

 
 

- เรียกใชฟงกช่ัน add xy data ใน ArcMap โดยไปที่ Tools ในเมนูบาร จากนั้นเลือก Add 
xy Data 
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- Click Browse หา text file ที่ทําการบันทึกขอมูลพิกัด x, y ไวแลว 
- เลือกชื่อคอลัมนที่กําหนดไว เชน x , y  

 

 
 

- ทําการ set spatial reference โดยกดปุม Edit จะปรากฏหนาตาง Spatial Reference 
Properties 
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- ในหนาตาง Spatial Reference Properties เลือก Coordinate System ที่ตองการ โดย Click 
Select แลวทําการเลือก Coordinate system 
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- เมื่อ Set spatial Reference เรียบรอยแลวให Click Apply > Click OK 
- จะปรากฏหนาตาง Add XY Data ที่ทําการ Set Spatial Reference แลว จากนั้น Click OK 

เพื่อสราง Point 
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- การนําเขาขอมลูจากโปรแกรม Excel สามารถทําไดโดยการ Save file เปนนามสกุล .dbf 
สามารถนํามาเปดใน Arcview 9 ได และใชคําส่ัง Add xy data และทําตามขั้นตอน
ขางตน 

 
การนําเขาขอมูลโดยการ Digitized 

 
- ตองทําการสราง Shapefile ขึ้นมาใหมในรูปแบบตางๆ โดยเปด ArcCatalog ซ่ึงจะเปดได

โดย Click ปุม   
 

 
 

- Click เลือก Drive และ Folder ที่ตองการเกบ็ File ที่สรางใหม 
- Click ขวา แลวเลือก New จากนั้นเลือก Shapefile จะปรากฏหนาตาง Create New 

Shapefile 
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- ตั้งชื่อ Shapefile ใหมที่ชอง Name สวนชอง Feature Type ใหเลือกรปูแบบที่จะทาํการ 
Digitized จากนั้น Click Edit 

 

 
 

- Set Spatial Reference โดย Click Select จากนั้นใหเลือก Coordinate Systems 
- Click Apply >  Click OK 
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- เมื่อ Set spatial Reference เรียบรอยแลวให Click OK 
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- เปด ArcMap แลวทําการ Add shapefile ที่เราสรางขึ้นมา โดย Click ปุม  ซ่ึง 
Shapefile ที่เพิม่เขามาจะยังไมมีขอมูลใดๆ อยูจนกวาเราจะทํา Digitize 

- เปด Editor tool ขึ้นมา โดย Click Tools บนเมนูบาร จากนั้นเลือก Editor Toolbar 
 

 
 

- หรือ Click ปุม  เพื่อเปด Editor tool ก็ได 
- จะปรากฏแถบเครื่องมือ Editor tool ขึ้นมา 

 

 
 

- เปด file ขอมูลที่จะทําการ Digitize เชน  file ภาพถายดาวเทียม 
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- Click Editor ที่ Editor Toolbar จากนั้นเลือก Start Editing แลวเลือก Shapefile ที่เราจะใช 
Digitize 
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- Click ปุม  (Sketch Tool) แลวจึงเริ่มการ Digitize 
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- เมื่อทําการ Digitize เสร็จแลว ให Click ปุม Editor ที่ Editor Toolbar จากนั้นเลือก Stop 
Editing แลว Click Yes เพื่อจัดเก็บงานที่เราทําการ Digitize 

 
 
 
 
 

 
 

2.3 การใชงานเครื่องมือหรอืฟงชั่นพื้นฐานของโปรแกรมประยุกต  ArcMap 
 

การเปดโปรแกรม 
 

- Click start menu > Programs > ArcGIS > ArcMap 
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การเปดโปรเจ็คใหม 
 

- เลือก A new empty map > Click OK 
 

 
การเปดโปรเจ็คท่ีมีอยูแลว 

 
- เลือก An existing map 
- เลือก File โปรเจ็คที่มีอยู > Click OK 
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การเพิ่มชั้นขอมูล 
 

- Click ปุม   บนแถบเครื่องมือเพื่อเพิ่มชั้นขอมูล 
 

 
 

- เลือกขอมูลที่จะเพิ่ม > Click Add 
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การจัดเก็บโครงงาน (Save project) 
 

- Click File > Save As 
 

 
 

- เลือกที่สําหรับ Save Project (เลือก Drive) 
- พิมพช่ือให Project > Click Save 

 

 
 

การใชชดุคําสัง่ ยอ, ขยาย, เล่ือนภาพ และการยอนกลับไปยังคําสัง่สุดทาย 
 

     1      2     3     4     5    6     7     8 

 
 

1 ใชสําหรับขยายภาพ 
2 ใชสําหรับยอภาพ 
3 ใชขยายแบบตรึง Scale 
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4 ใชยอแบบตรึง Scale 
5 ใชในการเลื่อนภาพ 
6 ใชในการดูแบบเต็มขอบเขตของภาพ 
7 ใชเพื่อยอนกลบัไปยังคําส่ังสุดทาย 
8 ใชเพื่อยอนไปการกระทําของคําส่ังที่เลิกทํา 

 
การขยายดูเฉพาะ Feature ท่ีถูกเลือก 

 

- Click ที่ปุม  แลวนํามา Click เลือก Feature ที่ตองการ 
 

 
 

- Click ขวาที่ Layer ของ Feature ที่ถูกเลือก 
- เลือก Selection > Zoom To Selected Features 
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-  
-  
-  
-  
-  
-  

- แสดงผลที่ไดจากการขยายดเูฉพาะ Feature ที่ถูกเลือก 
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การทํา Bookmark 
 

- เลือกพื้นที่ที่ตองการจะทํา Bookmark แลวขยายดพูื้นที่บริเวณนั้น 
 
 
 
 
 

- Click View > Bookmarks > Create 
 

 
 

- ตั้งชื่อใหพืน้ทีท่ี่ทํา Bookmark > Click OK 
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การเลือกดูพื้นที่ท่ีทําการ Bookmark 
 

- Click View > Bookmarks > พื้นที่ที่ทําการ Bookmarks ไว 
 

 
 

การ Select ขอมูลและการ Clear Selection  
 
 กรณีการ Select ขอมูลบนแผนที ่

- Click เลือก  บนแถบเครื่องมือ 
- นํามา Click ที่ Feature ที่ตองการเลือก 
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- หากตองการเลือกหลาย Feature ใหกด Shift ขณะที่ Click เลือกFeature ที่ตองการ 
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- ให Click เลือก  เหมือนการ Selection 
- นําลูกศรไป Click ยังจุดทีไ่มใชแผนที่ กจ็ะเปนการ Clear Selection แลว 

 

 
 

*** หากเปดตาราง Attribute พื้นที่ที่ถูกเลือกบนแผนทีก่็จะปรากฏแทบสีฟาแสดงการถูกเลือกขึ้นใน
ตาราง Attribute ของพื้นที่นัน้ ๆ ดวย 
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กรณีการ Select ขอมูลในตาราง Attribute 
- Click ขวาที่ Layer ที่ตองการเลือก > Click เลือก Open Attribute เพื่อเปดตาราง 

 

 
 

- Click ที่ชองสี่เหล่ียมหนาแถวของขอมูล (ดานซายของตาราง) ที่ตองการเลือก กรณี
ตองการเลือกหลายขอมูล ใหกด Ctrl ขณะที่ Click เลือกดวย 

 

 
 

การ Clear Selection ในตาราง Attribute  
 

- เปดตาราง Attribute > Click เลือก Option > เลือก Clear Selection 
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*** ในแผนทีจ่ะแสดงพื้นทีท่ี่ถูกเลือก พรอมกันกับที่มกีาร Click เลือกขอมูลในตาราง Attribute ดวย 

 
 

การ Set มาตราสวนของแผนที่ 
 

- Click View > Data Frame Properties 
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- บนหนาตาง Data Frame Properties ใหเลือกที่ General 
- เปลี่ยนหนวยในชอง Map ที่กรอบของ Units ใหเปนหนวยที่ตองการ เชน Meters 
- เปลี่ยนหนวยในชองของ Display ที่กรอบของ Units ใหเปนหนวยที่ตองการ แตโดยสวน

ใหญจะใชหนวยเดียวกับหนวยในชอง Map 
- Click Apply > Click OK 

 
 

- จะปรากฏชอง Map Scale ที่สามารถทําการเปลี่ยนคา Scale ไดโดยเลือกเปลี่ยนคา Scale 
ที่ชอง Map Scale 

 

 -33- 



โครงการจัดทําขอเสนอแนะเชิงนโยบายการจัดท่ีดินและการพัฒนาระบบขอมูล 

  

 
 

การใสและปรับแตง Label  
 

กรณีท่ีตองการใหแสดง Label ของ Feature ท้ังหมด 
- Double click Theme ที่จะทาํการใส Label 

 

 
 

- จะปรากฏหนาตาง Layer Properties ใหเลือก Label 
- ทําเครื่องหมาย  หนา Label Features in this layer 
- ในชอง Method กําหนดใหเปน Label all the features the same way เพื่อใหแสดง Label 

ของ Feature ทั้งหมด 
- ชอง Label Field ใหเลือก Field ที่ตองการจะแสดงขอมูล 
- Click Apply > Click OK  

 

 
- แสดงผลที่ไดจากการใส Label 
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รูปแสดงผลที่ไดจากการใส Label  

 
กรณีตองการแสดงขอมูลมากกวา 1 Field ใน 1 Feature 

 
- Click Expression 
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- เลือก Field ที่ตองการจะใหแสดงในชอง Label Fields แลว Click Add จนครบตามที่
ตองการ 

- Click Verify > Click OK   
 

 
 

- แสดงผลที่ไดจากการใส Label มากกวา 1 Field ใน 1 Feature 

 
รูปแสดงผลที่ไดจากการใส Label มากกวา 1 Field ใน 1 Feature 
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กรณีท่ีตองการแสดง Label เฉพาะ Feature ท่ีถูกเลือก 
- Double click Theme ที่จะทาํการใส Label  
- จะปรากฏหนาตาง Layer Properties ใหเลือก Label 
- ทําเครื่องหมาย  หนา Label Features in this layer 
- ในชอง Method กําหนดใหเปน Define classes of features and label each class 

differently เพือ่ใหแสดง Label เฉพาะ Feature 
- Click SQL Query 

 
 
 

- Double Click Field ที่ตองการจะใหแสดงหลังจากเลือก Field แลวในชอง Unique values 
จะปรากฏขอมลูของ Field นั้น 

- จากนั้นให Click ปุม  แลวDouble Click ขอมูลเฉพาะ Feature ที่ตองการจะให
แสดงในชองของ Unique Values 

- Click Verify > Click OK  
- จากนั้น Click Apply แลว Click OK ก็จะปรากฏ Label เฉพาะ Feature ที่เราเลือกเทานั้น 
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- แสดงผลที่ไดจากการแสดง Label เฉพาะ Feature ที่ถูกเลือก 
 

 
รูปแสดงผลที่ไดจากการแสดง Label เฉพาะ Feature ที่ถูกเลือก 

 
การเอา Label ออก (Remove Label) 
- Double Click Theme ที่ทําการใส Label ไว 
- จะปรากฏหนาตาง Layer Properties ใหเลือก Label 
- เอาเครื่องหมาย  หนา Label Features in this layer ออก 
- Click Apply แลว Click OK 
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การใสสีและปรับแตงสัญลักษณ 
 

การแกไขสัญลักษณและการทํา Thematic Map มีรายละเอียดคําส่ังดังนี้ 
- Single Symbol  ใชสัญลักษณเดยีวแทนขอมูลทั้งหมด 
- Categories - Unique values  แตละขอมลู ( แตละ Feature ) แสดงดวยสัญลักษณที่

แตกตางกัน  
- Quantities  แตละสัญลักษณจะแสดงขนาดของขอมูลที่แตกตางกัน เชน ใชความเขมของ

ชวงสีแบงตามคาของขอมูล  หรือใชขนาดสัญลักษณแสดงขอมูลที่มีปริมาณแตกตางกัน 
- Charts  ใชกราฟแสดงขอมูลในแผนที ่
- Multiple  Attributes การใชขอมูลมากกวา 1 ชุดในการจาํแนกขอมูล 

 
กรณีเลือกแบบ Single symbol 

 
- Double Click Theme ที่ตองการจะใสสี หรือปรับแตงสัญลักษณ  
- จะปรากฏหนาตาง Layer Properties 
- เลือกหนา Symbology แลวเลือก Feature จากนั้นเลือกเลือก Single symbol 
- Click สี หรือสัญลักษณ 
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- เลือกสีหรือสัญลักษณที่ตองการ แลว Click OK 
- Click Apply แลว Click OK 

 

 
 

วิธีลัด 
 

- Click สี หรือสัญลักษณ บนชื่อ Theme ที่ตองการจะเปลี่ยนสี หรือสัญลักษณ 
- เลือกสี หรือสัญลักษณ แลว Click OK 
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กรณีเลือกแบบ Unique values 

 
- Double Click Theme ที่ตองการจะใสสี หรือปรับแตงสัญลักษณ จะปรากฏหนาตาง 

Layer Properties 
- เลือกหนา Symbology แลวเลือก Categolies เลือก Unique values 
- ชอง Value Field ใหเปลี่ยนเปน Field ที่จะแสดงขอมูล 
- สามารถเลือกเปลี่ยนสีไดที่ชอง Color Scheme 
- Click Add All Values > Click Apply > Click OK 

 

 
  สามารถ Double Click เพื่อเปล่ียนสีได 
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กรณีเลือกแบบ Quantities 
 

- Double Click Theme ที่ตองการจะใสสี หรือปรับแตงสัญลักษณ จะปรากฏหนาตาง 
Layer Properties 

 
 

- เลือกหนา Symbology แลวเลือก Quantities  จากนัน้เลือกวิธีที่จะใหแสดงบนแผนที ่เชน 
เลือก Graduated colors ก็จะมีชองใหตั้งคาตางๆ เชนชอง Fields ใหตั้งคา Value และ 
Normalization  ชอง Classification และชอง Color Ramp เปนตน 

- Click Apply > Click OK 
 

 
 

กรณีเลือกแบบ Charts 
 

- Double Click Theme ที่ตองการจะใสสี หรือปรับแตงสัญลักษณ จะปรากฏหนาตาง 
Layer Properties 
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- เลือกหนา Symbology แลวเลือก Charts ในกรณีทีต่องการใหแผนที่นั้นแสดงแผนภูม ิ 
จะมีรูปแบบของ Charts ใหเลือก เชน Pie , Bar/Column และ Stacked ตัวอยางเชนเลือก 
Pie ก็จะตองตัง้คาตางๆ ในชองField Selection ใหเลือก Field ที่เราตองการใหแสดงเปน
แผนภูมิ อาจมFีieldเดียวหรือหลายFieldก็ได  

- Click   เพื่อ Add ขอมูล จะปรากฏชื่อ Field และสีสัญลักษณทางดานขวา ซ่ึง
สามารถ Clickเปลี่ยนสีได และสามารถปรับขนาดของ Pie ไดที่ปุม Size 

- เมื่อตั้งคาตาง ๆ เรียบรอยแลว Click Apply > Click OK 

 
 

การวัดระยะทางบนแผนที ่
 

- Click ปุม  บนแถบเครื่องมือ 
 

 
 

- Click ที่จุดเริ่มตนแลวลากไปยังเปาหมายของพื้นที่ที่ตองการทรายระยะทาง 
 

 -43- 



โครงการจัดทําขอเสนอแนะเชิงนโยบายการจัดท่ีดินและการพัฒนาระบบขอมูล 

  

 
   
              ตัวเลขบอกระยะทาง 
 

การใช Help 
 

การใช Help โดยอาศัยคาํคน 
 

- Click Help บนเมนูบารแลวเลือก ArcGIS Desktop Help  
 

 
 

- จะปรากฏหนาตาง ArcGIS Desktop Help 
- เลือกหนา Index ซ่ึงจะมีชองวางไวสําหรบัหัวขอที่ตองการคําอธิบาย หรือจะเลือกคาํคน

ที่มีอยูแลวก็ได 
- Click Display จะปรากฏคําอธิบายสําหรับหัวขอ หรือคําคนนั้นๆ 
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การใช Help เพื่ออธิบายการใชงานของแถบเครื่องมือ 
 

- Click Help บนเมนูบารแลวเลือก What’s This? หรือ Click ปุม  บนแถบเครื่องมือ 
ลูกศร Mouse จะเปลี่ยนไป 

 

 
- ใหนําลูกศรนัน้ไป Click แถบเครื่องมือที่ตองการทราบคําอธิบาย เมื่อ Click แลวจะ

ปรากฏหนาตางคําอธิบายถึงแถบเครื่องมือนั้นๆ 
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การสืบคนขอมูลจากแผนที ่
 

การใชเคร่ืองมอื Identify 

- Click ปุม  บนแถบเครื่องมือ 
 

 
 

- เล่ือน Mouse มา Click ในแผนที่บน Feature ที่ตองการใหแสดงขอมูล จะปรากฏ
หนาตาง Identify Result 

 

 
 

การใชเคร่ืองมอืคนหา 

- Click ปุม  บนแถบเครื่องมือ จะปรากฏหนาตาง Find 
 

 
 

- ที่ชอง Find ใหใสช่ือขอมูลที่ตองการคนหา 
- Click ปุม Find จะปรากฏขอมูลที่เราคนขึ้นมา 
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- Click ขวาแลวเลือก Zoom to feature(s) แผนที่จะแสดงภาพ Feature ที่เราสืบคนขึ้นมา 
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การสืบคนจากขอมูลเชิงบรรยาย (Select By Attributes) 
 

- Click Selection ที่เมนูบาร > Select By Attributes… 
 

 
 

- ที่ชอง Layer ใหเลือก Layer ที่ตองการสืบคน 
- Double click Field ที่ตองการสืบคนในชอง Field จะปรากฏขอมูลของ Fieldนั้นๆในชอง 

Unique values 
- Click เลือกเงือ่นไขที่ตองการ เชน =  , > , <  จากนั้นเลือกขอมูลที่ตองการจะสืบคนใน

ชอง Unique values 
- Click Verify > Click Apply ก็จะปรากฏ Feature ที่เราสืบคนในแผนที ่

 

 
 

* ถาตองการสืบคนแบบซับซอนใหเลือกวธีิการในในชอง Method 
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การสืบคนโดยอาศัยกฎเกณฑดานตาํแหนงท่ีตัง้ (Select By Location) 
 

เปนการสืบคนพื้นที่ โดยอาศัยเงื่อนไข และขอมูลตั้งแต 2 ช้ันขอมูลข้ึนไป เชน หากเราตองการ
เลือกพื้นที่อําเภอที่มีโรงงานอุตสาหกรรมตั้งอยู ก็จะใชขอมูล 2 ช้ันขอมูลข้ึนไป คือ ขอมูลพื้นที่อําเภอ
กับขอมูลจุดทีต่ั้งโรงงานอุตสาหกรรม ในการสืบคนตามวิธี Select By Location 

ในที่นี้จะยกตวัอยาง การสืบคนพื้นที่อําเภอในจังหวัดระยองที่มีสถานที่สําคัญตั้งอยู  
- Click Selection ที่เมนูบาร > Select By Location 

 

 
 

- ชอง I Want to: ใหเลือก select feature from 
- ชอง the following layers: ใหนําชั้นขอมูลที่ตองการสืบคน ในที่นีจ้ะยกตัวอยางโดยเลือก 

amphoe_pl ซ่ึงเปนขอมูลขอบเขตอําเภอของจังหวดัระยอง 
- ชอง that: ใหใสเงื่อนไขซึง่จะมีใหเลือก เชน intersect, are within a distance of, 

completely contain เปนตน 
- ชอง the features in this layer: ใหเลือกชัน้ขอมูลที่ใชเปนเงื่อนไขในการสืบคนอีก 1 ช้ัน

ขอมูล ในที่นีจ้ะยกตวัอยางโดยเลือก heritage ซ่ึงเปนจะแสดงขอมูลเปนจุดที่ตั้งสถานที่
สําคัญ 

- เมื่อกําหนดเงือ่นไขตางๆ เรียบรอยแลวให Click Apply  
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- แผนที่ก็จะเลือก Feature ที่เปนไปตามเงื่อนไขที่เราไดกาํหนดไวมาแสดง ซ่ึงในตัวอยาง
ที่ยกไวจะไดผลลัพธของอําเภอที่มีสถานที่สําคัญตั้งอยูซ่ึงมีอยู 3 อําเภอมาแสดง เปนตน 

 
*  การเลือกเงือ่นไขแบบตาง ๆ เลือกไดในชอง that ซ่ึงอาจมีเงื่อนไขหลาย ๆ แบบ
ใหเลือกในการสืบคนขอมูล 

 -50- 



คูมือการใชโปรแกรมระบบสารสนเทศภูมิศาสตร ArcGIS 9.2 
 

2.4 การแกไขขอมูล 
 

รูจักกับเคร่ืองมือแกไขขอมูล Editor Toolbar 
 
      1               2                                          3                                         4                                     5      6 

 
 

1 สวนของการ Set Editor 
2 ปุม Edit Tool ใชเลือกพื้นทีท่ี่ตองการแกไข 
3 ปุม Sketch Tool ใชสําหรับการ Digitize 
4 ชองแสดงถึงวธีิการตางๆ ในการแกไข 
5 ชองแสดงขอมูลที่ทําการแกไข 
6 ปุมสําหรับแกไข Attribute data 

 
การจัดการ Edit Session 

 
- กอนที่จะเริ่มทาํการแกไขขอมูลได ตองเขาไป Click Editor บน Editor Toolbar แลว

เลือก Start Editing จึงจะสามารถทําการแกไขขอมูลได 
 

 
 

การตั้งการ Snapping เพื่อไมใหเกิดการผิดพลาดในเรื่องของการที่จุดหรือเสนไมติดกันสนิท
 

- Click Editor บน Editor Toolbar แลวเลือก Snapping 
- ใหทําเครื่องหมาย  ในชอง Vertex Edge End ใน Layer ที่เราทําการแกไขอยู 
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การเลือกตําแหนงของ Feature 
 

- Click ปุม  (Edit Tool) บน Editor Toolbar แลว Click Feature ที่เราตองการเลือก 
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- ในการเลือก Feature มากกวา 1 Feature ให Click Mouse คางไว แลวลาก Mouse คลุม 
Feature ที่ตองการเลือก 

 

 
 

การหมุน Feature
 

- Click Editor จากนั้นเลือก Start Editing  

- Click ปุม  (Edit Tool) บน Editor Toolbar แลวเลือก Feature ที่ตองการจะหมนุ 

- Click ปุม  เพื่อทําการหมุน Feature 
 

 
 

- Click Feature ที่ตองการจะหมุน 
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การสราง Feature เพิ่ม (New Feature) 
 

- Click ปุม  บน Editor Toolbar ซ่ึงจะมีตัวเลือกในการ Sketch ใหเลือก ซ่ึงตามปกติ
แลวมักจะใชปุม  ในการ Digitize 

 

 
 

- จากนั้นทาํการวาดตามตองการ 
 
 
 
 
 
 
 
 

การเพิ่ม, ลบ และยายตําแหนง Vertex
 

- กอนอ่ืนจะตองทําการ Start Editing ช้ันขอมูลของ Feature ที่จะทําการเพิ่ม ลบ และยาย
ตําแหนง Vertex กอน 

- Click ปุม  บน Editor Toolbar แลวจึงไป Double click Feature ที่ตองการจะ Edit 
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การเพิ่ม 
 

- Click ขวาที่เสนระหวางจุด (Vertex) ที่เราตองการเพิ่มจุด (vertex) แลวเลือก Insert 
Vertex 

 

 
 

การลบ 
 

- Click ขวาที่จุด (Vertex) ที่เราตองการลบ แลวเลือก Delete Vertex 
 

 
 

การเปล่ียนรูปราง Feature (Reshape) 
 

- ถาเราตองการแกไขหรือยายเล่ือนจุด (Vertex) ให Click ซายคางที่จุด (Vertex) นั้น แลว
ทําการแกไขรปูรางตามความตองการ 
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การยาย Feature (Move) 
 

- เราสามารถทําการยาย Feature ไดโดยการ Start Editing ที่ปุม Editor บน Editor Toolbar 

- Click ที่ปุม  บน Editor Toolbar 
- นําลูกศรมา Click ยัง Feature ที่ตองการยาย 
- Click คางเพื่อลาก Feature นั้นๆ ตามตองการ 
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การกําหนดความยาวและทิศทางของเสน 
 

- หากตองการลากเสน (Digitize) โดยใชปุม  บน Editor Toolbar เราสามารถกําหนด
ความยาวและทิศทางของเสนได 

- Click Editor บน Editor Toolbar > Start Editing 
 
การกําหนดความยาว 

 
- จากจุดเริ่มตนของเสนเมื่อลากไประยะหนึ่ง ให Click ขวาเลือก Length และกําหนด

ความยาวของเสนแลวปด ก็จะไดความยาวตามที่เรากําหนด 
 

 
 

  
 

 
 

 
 

การกําหนดทศิทางของเสน 
 

- จากจุดเริ่มตนของเสนเมื่อลากไปสักหนอย ให Click ขวาเลือก Direction เพื่อเลือก
ทิศทางของเสนแลวปด ก็จะไดทิศทางของเสนตามที่เราใสคาไป 
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การแบง Polygon 
 

- ในการตัด Polygon จะตองทาํการเลือกที่ Task บน Editor Toolbar โดยเปลี่ยนวิธีในชอง 
Task ใหเปน Cut Polygon Features กอน 

 

 
 

- จากนั้น Click เลือก Polygon ที่จะทําการตดั 
- Click ปุม  แลวลากเสนผานบริเวณที่เราจะตัดดังรูป 

 

 
 

- จากนั้น Click ขวาแลวเลือก Finish Sketch จะไดผลลัพธออกมาเปนเปน 2 Polygon ดัง
รูป 
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การแกไข Attribute data ของ Selected feature 
 
- Click Feature ที่เราตองการแกไข 

- จากนั้น Click ปุม  บน Editor Toolbar ของ Feature นั้น 
- จะปรากฏหนาตาง Attributes ที่สามารถแกไข Id ของ Feature ได เชน จาก ID = 0 เปน 

ID = 30 ดังรูป 
 

 

2.5 การจัดตารางขอมูลเชิงบรรยาย (Attribute data) 
 

การเปดตาราง 
 

- Click Layer ที่เราจะใหแสดงขอมูลเชิงบรรยาย (Attribute) 

 
- แลว Click ขวา  Layer ที่เราจะใหแสดงขอมูลเชิงบรรยาย (Attributes) 
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- เลือก Open Attribute Table ขอมูลเชิงบรรยาย (Attribute) ก็จะแสดงขึน้มา 
 

 
 

การแกไขตาราง 
 

- ในการแกไขตารางเราจําเปนตองทําการ Start Edit กอน 
- Click Editor > Start Editing 
- เปดตารางที่เราตองการจะทาํการแกไข และ Click ไปที่ขอมูลที่จะแกไข 
- จากนั้นก็เร่ิมทาํการพิมพแกไขได 

 
 
 
 
 
 
 
 
 

การเพิ่มคอลัมน (Add Field) 
 

- Click Option ในตารางแลวเลือก Add Field 
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- จะปรากฏหนาตาง Add Field ขึ้นมา  
- ตั้งชื่อ Field ใหมในชอง Name 
- ในชอง Type ใหเปลี่ยนลักษณะของขอมูลที่ตองการใหแสดงใน Field ที่สรางขึ้นใหม 

เชน ตองการใหเปนตวัเลขกใ็หเลือก Short Integer หรือ Long Integer ถาตองการใหเปน
ตัวอักษรก็ใหเลือก Text เปนตน 

- Click OK จะแสดง Field ใหมขึ้นมาบนตาราง 
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การเรียงลําดับ Record ใน Field ท่ีตองการ 
 

- Click ขวาที่หวั Field แลวเลือก Sort Ascending (เรียงจากนอยไปหามาก) หรือเลือก Sort 
Descending ( เรียงจากมากไปหานอย) ดังรูป 
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การคํานวณคาใน Field ท่ีกําหนด 
 

- ในที่นี้จะทําการคํานวณพื้นทีอํ่าเภอใหมีหนวยเปนไร (จากเดิมเปนตารางเมตร) โดยทีจ่ะ
ใสคาไว Field ที่สรางขึ้นใหมตามวิธีการเพิ่มคอลัมนที่ไดกลาวไปแลว โดยใชช่ือใหมวา 
area_rai 

 

 
 

- Click ขวาที่หวัขอ Field area_rai เพื่อเรียกฟงกช่ัน Calculate Values 
 

 
 

- จะปรากฏหนาตาง Field Calculator จากนั้นใหใสสูตรการคํานวณเนือ้ที่ตารางเมตรให
เปนไร คือ พื้นที่ (ตารางเมตร)/1600 = พื้นที ่(ไร) 

- วิธีการใสสูตรคือ Double click Field ที่ตองการจะแปลงหนวย ตามดวยฟงกช่ันการ
คํานวณ และตวัเลขใหเหมือนกับสูตรจากนั้น Click OK 

- ดังจะยกตวัอยางการแปลงพืน้ที่อําเภอจากหนวยตารางเมตรใหเปนไร คือ Double click 

Field Area ตามดวยเครื่องหมายหาร ( ) และตัวเลข 1600 จากนั้น Click OK 
 

 -63- 



โครงการจัดทําขอเสนอแนะเชิงนโยบายการจัดท่ีดินและการพัฒนาระบบขอมูล 

  

 
 

- จะไดผลลัพธของการคํานวณการแปลงหนวยพื้นที่อําเภอจากตารางเมตรเปนไร ดังแสดง
ในรูป 
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2.6 การสรางแผนที่ 
 

การเปด Layout View 
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การใชเคร่ืองมอื Layout tool 
 

 

 

 

 

 

Zoom in 
Zoom out Pan 

Fixed zoom out Fixed zoom in 

Zoom whole page 

Zoom to 100% 

Go back to extent 

Go forward to extent 

Zoom control 

Change layout 

การเลือกTemplate 
 

 

 

 

 

 

 

การเลือกขนาดกระดาษที่จะผลิตแผนที ่
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การกําหนดมาตราสวนและขนาดกรอบของแผนที ่
 

 

 

 

 

 

 

 

 

 

 

 

การใสชื่อแผนที ่
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การใสคําอธิบายสัญลักษณ 
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การใสทิศ 
 

 

    

 

 

 

 

 

 

 

 

 

การใสมาตราสวน 
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การใสเสนกริด 
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การสั่งพิมพแผนที ่
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การ Export map 
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